About esnu

Me Myself n I

CARA SHARING FILE DARI LINUX UBUNTU KE WINDOWS

Pertama install paket samba di sini saya menginstall secara online maka koneksikan ke jaringan internet terlebih dahulu, lalu buka terminal Ctrl + Alt + T dan ketik perintah:

sudo su [enter]

Kemudian masukan password linux Ubuntu kamu ketika memasukan password bisanya tidak terlihat langsung tekan ENTER.

sudo apt-get update [enter]

sudo apt-get install samba [enter]

jika sudah menginstall paket samaba langsung ke pengaturan sharing file pada Ubuntu ada dua cara yang pertama berbasis CLI (Command Line Interface) “di terminal dengan gedit text editor” yang  kedua GUI (Graphical User Interface) “di klik kanan di folder yang akan di share”,

  1. Sharing Berbasis GUI

Klik kanan di folder yang akan di sharing di sini saya menggunakan folder Aku -> pilih Properties.

Pilih Permissions -> pada Group pilih sambashare -> pada semua Access pilih Create and delete files.

Selanjutnya pilih tab sebelah kanannya Local Network Share -> ceklis semuanya -> pilih Create Share.

Cek di komputer Windows apakah folder Aku berhasil di share, caranya ketik Ip komputer linux ubuntu di address bar windows \\192.168.17.2 gambar di bawah folder yang berhasil di share

  1. Sharing Berbasis CLI

Disini saya menggunakan gedit text editor via terminal caranya buka terminal Ctrl + Alt + T lalu kamu masuk sebagai root dengan mengetikan perintah:

sudo su [enter]

Kemudian masukan password linux Ubuntu kamu ketika memasukan password bisanya tidak terlihat langsung tekan ENTER. Buka konfigurasi samba dengan mengetikan perintah:

gedit[spasi]/etc/samba/smb.conf [enter]

akan muncul samba config berbasis text warna putih, scroll ke paling bawah dan ketik perintah di bawah untuk membuat konfigurasi sharing, setelah selesai klik Save lihat gambar.

[Bagi1] ==> ini yang akan menjadi nama folder ketika ditampilkan di windows

path = /home/yusuplinux16/Bagi1 ==> ini alamat folder yang akan di bagi

commant = folder share ==> hanya keterangan

browseable = yes

read only = yes

writable = yes

guest ok = yes

create mask 0777

Kemudian buat folder Bagi1 via terminal buka terminal ketik perintah dibawah:

mkdir[spasi]/home/yusuplinux16/Bagi1 [enter]

Jika sudah dibuat foldernya, lalu ketikan perintah berikut agar client bisa mengakses secara penuh pada folder ini.

chmod[spasi]0777[spasi]/home/yusuplinux16/Bagi1 [enter]

Lalu restart konfigurasi samba ketik perintah berikut:

/etc/init.d/samba restart [enter]

Cek di komputer Windows apakah folder Bagi1 berhasil di share, carannya ketik Ip komputer linux ubuntu di address bar windows \\192.168.17.2 gambar di bawah folder yang berhasil di share

Selesai…!!!

Advertisements

Block download based on file SIZE …

I forgot the guy’s name who is from FB, who asked me a question, lets name him Mr. X. The query was > howto block downloads of large files (lets say 5mb or above ) in specific timings (like 8pm-12am).

But the issue is How the router will know the file size before it’s downloaded? The router has no way of knowing how big a connection is… An workaround is to create a Firewall Filter rule that will will allow the first 5MB of a connection through, and once it reaches that, it will start to drop packets. I used it a network in Gulistan-e-Jauhar, and it worked good.
But do remember that that It will also affect streaming, RDP like protocols, VPNs, and any other connection that transfers a large number of bytes.

/ip firewall filter
add action=drop chain=forward comment="downloading of files larger then 5mb (It will break connection after 5mb of transfer) applicable from 8pm till 12am / zaib" connection-bytes=5242880-0 disabled=no protocol=tcp time=\
20h-23h59m59s,sun,mon,tue,wed,thu,fri,sat

 

source : https://aacable.wordpress.com/tag/lock-download-based-on-file-size/

Mikrotik How to block Winbox Discovery + Limit Winbox Access

To hide your mikrotik from being appearing in WINBOX scan negibour list, & to limit WINBOX access from your admin PC only,
Use the Following.

/tool mac-server
add disabled=yes interface=all
/tool mac-server ping
set enabled=no
/ip firewall filter
add action=drop chain=input comment="block mikrotik discovery" disabled=no dst-port=5678 protocol=udp
add action=drop chain=input comment="ALL WINBOX REQUEST By MAC Address" disabled=no dst-port=20561 protocol=udp
add action=drop chain=input comment="ALL WINBOX REQUEST EXCEPT FROM MY PC" disabled=no dst-port=8291 protocol=tcp src-address=!192.168.2.6

You can Also Disable Network Neighbor Discovery on the interface to which your network users are connected

Example: /ip neighbor discovery set ether1 discover=no

source : https://aacable.wordpress.com/tag/lock-download-based-on-file-size/

A BETTER APPROACH ON BLOCKING PORTS !

/ip firewall mangle
add action=add-src-to-address-list address-list=Worm-Infected-p445 address-list-timeout=1h chain=prerouting connection-state=new disabled=no dst-port=445 limit=5,10 protocol=tcp
/ip firewall filter
add action=drop chain=forward disabled=no dst-port=445 protocol=tcp src-address-list=Worm-Infected-p445
add action=drop chain=forward disabled=no dst-port=445 protocol=tcp src-address-list=Worm-Infected-p445
source : https://aacable.wordpress.com/tag/lock-download-based-on-file-size/

HOWTO PREVENT VIRUS / PORTS FLOODING ?

A basic Mikrotik Firewall Script to secure MT box from virus and flooding. First copy all contents of below script to notepad, then carefully read it.

/ip firewall filter
# To Block ICMP on your WAN Interface
add action=drop chain=input comment="Block ICMP on WAN interface" in-interface=pppoe-out1 protocol=icmp
# Add flooding ips coming from the internet to the Blocked List for 1 mnt
add action=jump chain=forward connection-state=new jump-target=block-ddos
add action=drop chain=forward connection-state=new dst-address-list=ddosed src-address-list=ddoser
add action=return chain=block-ddos dst-limit=50,50,src-and-dst-addresses/10s
add action=add-dst-to-address-list address-list=ddosed address-list-timeout=1m chain=block-ddos
add action=add-src-to-address-list address-list=ddoser address-list-timeout=1m chain=block-ddos
# Block DNS Request on INCOMING WAN INTERFACE
add action=drop chain=input comment="BLOCK DNS REQUEST ON WAN INTERFACE" dst-port=53 in-interface=pppoe-out1 protocol=udp
# Block PORT Scanner Users for 2 minutes
add action=drop chain=input comment="ping port scanners" src-address-list="port scanners"
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2m chain=input comment="Port scanners to list " protocol=tcp psd=21,3s,3,1
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2m chain=input comment="NMAP FIN Stealth scan" protocol=tcp tcp-flags=fin,!syn,!rst,!psh,!ack,!urg
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2m chain=input comment="SYN/FIN scan" protocol=tcp tcp-flags=fin,syn
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2m chain=input comment="SYN/RST scan" protocol=tcp tcp-flags=syn,rst
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2m chain=input comment="FIN/PSH/URG scan" protocol=tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=30m chain=input comment="ALL/ALL scan" protocol=tcp tcp-flags=fin,syn,rst,psh,ack,urg
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2m chain=input comment="NMAP NULL scan" protocol=tcp tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg
# Block Common Virus Ports
add action=drop chain=virus comment="Blaster Worm" dst-port=135-139 protocol=tcp
add action=drop chain=virus comment="Blaster Worm" dst-port=445 protocol=tcp
add action=drop chain=virus comment="Messenger Worm" dst-port=135-139 protocol=udp
add action=drop chain=virus comment="Blaster Worm" dst-port=445 protocol=udp
add action=drop chain=virus comment=________ dst-port=593 protocol=tcp
add action=drop chain=virus comment=________ dst-port=1024-1030 protocol=tcp
add action=drop chain=virus comment=MyDoom dst-port=1080 protocol=tcp
add action=drop chain=virus comment=________ dst-port=1214 protocol=tcp
add action=drop chain=virus comment="ndm requester" dst-port=1363 protocol=tcp
add action=drop chain=virus comment="ndm server" dst-port=1364 protocol=tcp
add action=drop chain=virus comment="screen cast" dst-port=1368 protocol=tcp
add action=drop chain=virus comment=hromgrafx dst-port=1373 protocol=tcp
add action=drop chain=virus comment=cichlid dst-port=1377 protocol=tcp
add action=drop chain=virus comment="Bagle Virus" dst-port=2745 protocol=tcp
add action=drop chain=virus comment=Dumaru.Y dst-port=2283 protocol=tcp
add action=drop chain=virus comment=Beagle dst-port=2535 protocol=tcp
add action=drop chain=virus comment=Beagle.C-K dst-port=2745 protocol=tcp
add action=drop chain=virus comment=MyDoom dst-port=3127-3128 protocol=tcp
add action=drop chain=virus comment="Backdoor OptixPro" dst-port=3410 protocol=tcp
add action=drop chain=virus comment=Sasser dst-port=5554 protocol=tcp
add action=drop chain=virus comment=Beagle.B dst-port=8866 protocol=tcp
add action=drop chain=virus comment=Dabber.A-B dst-port=9898 protocol=tcp
add action=drop chain=virus comment=Dumaru.Y dst-port=10000 protocol=tcp
add action=drop chain=virus comment=MyDoom.B dst-port=10080 protocol=tcp
add action=drop chain=virus comment=NetBus dst-port=12345 protocol=tcp
add action=drop chain=virus comment=Kuang2 dst-port=17300 protocol=tcp
add action=drop chain=virus comment=SubSeven dst-port=27374 protocol=tcp
add action=drop chain=virus comment="PhatBot, Agobot, Gaobot" dst-port=65506 protocol=tcp
add action=jump chain=forward comment="jump to the virus chain" jump-target=virus
add chain=input comment="Accept established connections" connection-state=established
add chain=input comment="Accept related connections" connection-state=related
add action=drop chain=input comment="invalid connections" connection-state=invalid
add chain=input comment=UDP protocol=udp
add action=drop chain=forward comment="invalid connections" connection-state=invalid
# Script Ends Here

Everything You Need to Know About SLC, MLC, & TLC NAND Flash

The Anatomy of an SSD

MyDigitalSSD BP4e mSATA SSD 

MyDigitalSSD BP4e mSATA SSD with two enclosed NAND flash memory chips installed. The controller chip is designed by PHISON

  • A. NAND Flash: The part where your data is stored, in blocks of non-volatile (does not require power to maintain data) memory.
  • B. DDR Memory: Small amount of volatile memory (requires power to maintain data) used to cache information for future access. Not available on all SSDs.
  • C. Controller: Acts as the main connector between the NAND flash and your computer. The controller also contains the firmware that helps manage your SSD.

What is NAND Flash?

NAND flash memory is built up of many cells that holds bits, and those bits are either turned on or off through an electric charge. How those on/off cells are organized represents the data stored on the SSD. The number of bits in those cells also determine the naming of the flash, for example Single Level Cell (SLC) flash contains a single bit in each cell.

The reason behind SLC only being available at lower capacities is down to the physical real estate the NAND flash occupies on the Printed Circuit Board (PCB). Don’t forget that the circuit board has to have the controller, DDR memory, and flash built to standard dimensions to fit inside your computer. MLC doubles the amount of bits per cell, whereas TLC triples, and this opens up for higher capacity SSDs.

There are particular reasons why manufactures build flash memory with a single bit per cell like SLC. SLC has the advantage of being the fastest, most durable but has the cons of being more expensive, and is not available in higher gigabyte storage capacity. That is why SLC is preferred for heavy enterprise usage.

MLC and TLC flash in comparison to SLC, is cheaper to produce, available in higher storage capacities, but at the tradeoff of relatively shorter life spans and slower read/write speeds. MLC and TLC are preferred for everyday consumer computer usage.

Understanding your own needs for computing and NAND flash basics will not only help you pick the right SSD, but will also help you figure out factors such as the price behind the product.


SLC (Single Level Cell)

The Single Level Cell flash is so called for it’s single bit that can either be on or off when charged. This type of flash has the advantage of being the most accurate when reading and writing data, and also has the benefit of lasting the longest data read and write cycles. Program read/write life cycle is expected to be between 90,000 and 100,000. This type of flash has done exceptionally well in the enterprise market because of it’s life span, accuracy and overall performance. You won’t see too many home computers with this type of NAND due to its high cost and low storage capacities.

Pros:

  • Has the longest lifespan and charge cycles over any other type of flash.
  • More reliable smaller room for read/write error.
  • Can operate in a broader temperature range.

Cons:

  • The most expensive type of NAND flash on the market.
  • Often only available in smaller capacities.

Recommended for:

  • Industrial use and workloads that require heavy read/write cycles such as servers.

eMLC (Enterprise Multi Level Cell)

eMLC is MLC flash, but optimized for the enterprise sector and has better performance and lastability. Read/write data life cycles are expected between 20,000 and 30,000. eMLC provides a lower cost alternative to SLC, yet maintains some of the pros of SLC.

Pros:

  • Cheaper alternative than SLC for an enterprise SSD.
  • Has better performance and endurance over standard MLC.

Cons:

  • Does not match SLC NAND flash SSDs in performance.

Recommended for:

  • Industrial use and workloads that require heavy read/write cycles such as servers.

MLC (Multi Level Cell)

MLC flash as it’s name suggests stores multi bits of data on one cell. The big advantage of this is the lower cost of manufacturing versus manufacturing SLC flash. The lower cost in flash production is generally passed onto you as the consumer, and for that reason is very popular among many brands. MLC flash is preferred for consumer SSDs for it’s lower costs but the data read/write life is less in comparison to SLC at around 10,000 per cell.

Pros:

  • Lower production costs are passed onto you the consumer.
  • Is more reliable than TLC flash.

Cons:

  • Not as durable and reliable as SLC or enterprise SSDs.

Recommended for:

  • Everyday consumer use, gamers, and enthusiasts.

TLC (Triple Level Cell)

Storing 3 bits of data per cell, TLC flash is the cheapest form of flash to manufacture. The biggest disadvantage to this type of flash is that it is only suitable for consumer usage, and would not be able to meet the standards for industrial use. Read/write life cycles are considerably shorter at 3,000 to 5,000 cycles per cell.

Pros:

  • Cheapest to manufacture which in turn leads to cheaper to market SSDs.

Cons:

  • Cells will survive considerably less read/write cycles compared to MLC NAND. This means that TLC flash is good for consumer use only.

Recommended for:

  • Everyday consumer use, web/email machines, netbooks, and tablets.

The SSD Life Cycle

Like all good things, an SSD does not last forever. As noted above, a solid state drive’s life cycle can be directly attributed to the NAND flash it comes with. SLC flash, for example, will last longer than MLC or TLC flash but that comes at a hefty price tag.

With MLC and TLC flash commonly used/found in consumer SSDs, the real question is how long will they last?

TechReport.com has tested several available consumer-grade SSDs, most of which were MLC NAND with one being TLC NAND, and the results are promising. All of the devices tested lasted at least 700 terabytes (TB) of writes before failing, and a couple even pushed passed a petabyte (PB).

This is a lot of data, but let’s put that into perspective in writing 1 PB to an SSD.

1 petabyte (PB) = 1,000 terabytes (TB) / 1,000,000 gigabytes (GB) / 1,000,000,000 (MB)

That 1 PB could net you:

  • 222,222 movie DVDs at 4.5GB a DVD
  • 333,333,333 mp3 songs at 3MB a song
  • 500,000,000 jpg photos at 2MB an image
  • 15,384 installs of the game Grand Theft Auto V at 65GB an install

Looking at those numbers should really put to rest any doubts about your SSD failing in any short amount of time.

If you are considering an MLC or TLC SSD for everyday consumer use like; storing music, photos, software, personal documents or play games then you should feel assured that your SSD should last several years. This kind of usage is considered light compared to the ongoing heavy read/write usage of enterprise servers and computers as outlined in the next section below.

Note: For anyone worried about the lifespan of their SSD, features such as Self-Monitoring Analysis and Reporting Technology, or S.M.A.R.T. for short, can help you better keep track of your SSD’s longevity.


Enterprise vs. Consumer SSDs

Enterprise SSDs are commonly found in database servers.The difference and demands expected of enterprise SSDs set them a world a part from consumer SSDs. Enterprise SSDs are designed to meet a higher standard, and consistently perform in high-tech services, military, science and any area that would require a large amount of reading and writing data.

Database servers are an example of where you might see an enterprise SSDs, these servers are on 24/7 and that includes: longer read/write life cycle, faster read/write speeds, increased reliability and durability in harsh environments.

Consumer SSDs are less expensive, and are stripped down versions of enterprise SSDs. This may sound like you are missing out on certain features, but the benefits of a cheaper product with larger storage capacity are worth it. Besides manufactures are always increasing the performance of SSDs while bringing down the price.


In Conclusion

At this point, you probably have a good idea on the difference between SLC, MLC, and TLC NAND flash. The basics we discussed here, with insight into why some cost more than others, should clear up any confusion as to what type of flash best fits your needs.

Flash Type

SLC

Single Level Cell

eMLC

Enterprise
Multi-Level Cell

MLC

Multi-Level Cell

TLC

Triple-Level Cell

Read/Write Cycles 90,000-100,000 20,000-30,000 8,000-10,000 3,000-5,000
Bit Per Cell 1 2 2 3
Write Speed ★★★★★ ★★★★☆ ★★★☆☆ ★★☆☆☆
Endurance ★★★★★ ★★★★☆ ★★★☆☆ ★★☆☆☆
Cost ★★★★★ ★★★★☆ ★★★☆☆ ★★☆☆☆
Usage Industrial/Enterprise Industrial/Enterprise Consumer/Gaming Consumer

The important thing to take away from this guide is that modern SSDs are built to last a considerable amount of time. While their life-cycle should be taken into account, it should by no means prevent you from buying faster and more efficient storage.

 

Comments on Everything You Need to Know About SLC, MLC, & TLC NAND Flash

MyDigitalDiscount.com Friday, January 6, 2017 08:37:59
Frank,

We have not encountered an eSLC as of yet. SLC flash on its own is a high-grade flash, and low capacity aside is more than suitable for enterprise applications

Frank Thursday, January 5, 2017 13:42:01
How to buy eslc. canot find
Bill Friday, December 30, 2016 08:33:16
A very good explanation written in such a way that a typical computer user can understand the basics without their eyes glazing over. There are several typos which are distracting however.
Midhun Lohidakshan Wednesday, December 7, 2016 02:33:55
Very useful information.Thanks!
Prasad Pattadakal Monday, November 28, 2016 01:12:24
Helpful Article. Easy to understand
Ben Sunday, October 2, 2016 13:24:51
I wonder if it is possible, to overcome the electron lingering problem with TLC, by periodically scheduling,during data wear leveling, to leave each entire block full of zeros for a time, before again re-using it? This would be a form of Tender Loving Care 😉
Sylvain Saturday, October 1, 2016 05:46:05
Thanks for the clean explanation 🙂
Rathlo Friday, September 30, 2016 04:23:52
Just FYI: The conversions from petabytes, terabytes and giogabytes should be 1024 based: 1PB = 1024 TB, 1 TB = 1024 GB, 1GB = 1024 MB.
MyDigitalDiscount.com Wednesday, August 24, 2016 09:59:44
Evelyn,

SLC, MLC, and TLC are all considered NAND flash. The difference between the SLC, MLC, and TLC is in their construction and physical design. For this reason, no firmware can change one type of NAND flash to the other.

Firmware updates can improve reliability and performance, so it is always best to consider updates offered from your SSD manufacturer’s website.

Evelyn Wednesday, August 24, 2016 05:11:32
Is the NAND flash used for SLC, MLC and TLC the same? Or the TLC can be converted to SLC thru firmware?
MyDigitalDiscount.com Friday, August 5, 2016 09:52:49
Eric Hoyer,

Thank you, glad it helped. /
Vielen Dank, froh, es half.

Eric Hoyer Friday, August 5, 2016 04:37:02
Hallo
ist ein guter Beitrag, so kann man erkennen was die leisten und was zu kaufen ist.

Mit freundlichem Gruß
Eric Hoyer

——————–

(Google Translate – Ger – Eng)

Hello
is a good contribution , so you can see what the make and what to buy .

Sincerely
Eric Hoyer

MyDigitalDiscount.com Friday, March 18, 2016 16:42:23
Ankush,

Thank you for your comment, and your suggestion. SSD lifecycle is something that needs to be understood so that you can continue to operate and secure your data. If you do not have software that monitors your SSD’s status you can always check out Crystal Disk Info. It is a free to use utility found here: http://tinyurl.com/6x7xc3

Going into further detail about the information from Crystal Disk Info with the information provided by an SSD manufacturer would prove for an interesting article.

Ankush Thursday, March 17, 2016 09:44:47
Great article and really helpful. I have already purchased a TLC variant of SSD and was wondering how much time before I would have to part away from my $100. That being said, I never backed up my HDDs till now. I just copied off all the data from my old computers onto the new ones. A comparison of HDD and SSD lives will be appreciated, if you ever get time.

Thanks again.

MyDigitalDiscount.com Wednesday, August 12, 2015 12:50:05
Simon,

This article serves as an introduction to NAND flash and ignores other components and factors that can affect read/write speed. We are comparing the different flash types against each other, and TLC flash is considered slower in speed vs MLC flash.

The speed difference from a consumer stand point will be minimal or not noticeable

Simon Tuesday, August 11, 2015 20:42:15
There is some incorrect information here.
For example, MLC in itself does not guarantee faster write speeds.

Source : http://www.mydigitaldiscount.com/everything-you-need-to-know-about-slc-mlc-and-tlc-nand-flash.html

[Linux] Cara Mengganti Repository Ubuntu 16.04 LTS dari Server Luar ke Server Lokal

Penjelasan Apa itu Repository?

Saya akan menjelaskan terlebih dulu apa itu repository atau yang biasa dipanggil repo.

Repository adalah tempat disimpannya berbagai aplikasi atau program yang telah dibuat sedemikian rupa sesuai dengan kebutuhan para pengguna linux.

Repository dapat diakses melalui internet, selain dari internet repository juga tersedia dalam bentuk DVD sebagai alternatif jika tidak ada koneksi internet.

Kenapa atau Apa Keuntungan Merubah Repository Ubuntu Server Luar ke Server Lokal?

Kenapa harus mengganti repository ubuntu ke server lokal? atau Apasih keuntungan merubah repository ubuntu ke server lokal?

Jawabannya adalah agar saat proses instalasi program atau aplikasi bisa lebih cepat, karena menggunakan server lokal yang ada didalam negeri bukan server yang ada di luar negeri.

Mengecek Versi Linux Ubuntu yang Digunakan

Sebelum mengganti repository linux ubuntu yang kita gunakan, pastikan dulu versi linux ubuntu-nya. Untuk mengecek versi linux ubuntu, jalankan perintah dibawah ini pada terminal/shell:

$ lsb_release -a

Cara Mengganti Repository Ubuntu

Ada 2 langkah untuk mengganti atau merubah repository ubuntu.

1. Edit File Konfigurasi Repository

Nama file konfigurasi repository ubuntu adalah source.list, lokasi file ini terletak pada direktori /etc/apt/. Untuk mengedit file tersebut kita akan menggunakan editor text nano.

Sebelum melakukan perubahan ada baiknya kita backup dulu file originalnya dengan menjalankan perintah berikut ini:

# cp /etc/apt/source.list /etc/apt/source.list.original

Setelah melakukan proses backup, dilanjutkan dengan mengedit file source.list. Disini kita akan menggunakan editor text nano.

# nano /etc/apt/source.list

Setelah file dibuka, hapus semua isi file tersebut lalu ganti dengan repositoy lokal ubuntu 16. Anda dapat melihatnya di dalam artikel ini.

Contoh kita menggunakan repository lokal ubuntu 16.04 via Kambing UI maka isi file source.list akan terlihat seperti ini:

deb http://kambing.ui.ac.id/ubuntu/ xenial main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu/ xenial-updates main restricted universe multivers
deb http://kambing.ui.ac.id/ubuntu/ xenial-security main restricted universe multivers
deb http://kambing.ui.ac.id/ubuntu/ xenial-backports main restricted universe multivers
deb http://kambing.ui.ac.id/ubuntu/ xenial-proposed main restricted universe multiverse

Setelah itu Save dengan menekan tombol Ctrl+O, lalu Exit dengan menekan tombol Ctrl+X.

Untuk mengganti atau merubah isi file source.list kita perlu masuk ke dalam mode superuser atau root.

2. Update Repository Ubuntu

Proses update diperlukan setelah merubah repository, agar linux ubuntu yang kita gunakan langsung mengenali server mana yang akan dipakai nantinya untuk proses update maupun install aplikasi atau program.

Berikut ini perintah update-nya:

# apt-get update

Selesai. cheers 😀

Source : http://cubnetwork.com/cara-mengganti-repository-ubuntu-16-04/