Block download based on file SIZE …

I forgot the guy’s name who is from FB, who asked me a question, lets name him Mr. X. The query was > howto block downloads of large files (lets say 5mb or above ) in specific timings (like 8pm-12am).

But the issue is How the router will know the file size before it’s downloaded? The router has no way of knowing how big a connection is… An workaround is to create a Firewall Filter rule that will will allow the first 5MB of a connection through, and once it reaches that, it will start to drop packets. I used it a network in Gulistan-e-Jauhar, and it worked good.
But do remember that that It will also affect streaming, RDP like protocols, VPNs, and any other connection that transfers a large number of bytes.

/ip firewall filter
add action=drop chain=forward comment="downloading of files larger then 5mb (It will break connection after 5mb of transfer) applicable from 8pm till 12am / zaib" connection-bytes=5242880-0 disabled=no protocol=tcp time=\
20h-23h59m59s,sun,mon,tue,wed,thu,fri,sat

 

source : https://aacable.wordpress.com/tag/lock-download-based-on-file-size/

Advertisements

Mikrotik How to block Winbox Discovery + Limit Winbox Access

To hide your mikrotik from being appearing in WINBOX scan negibour list, & to limit WINBOX access from your admin PC only,
Use the Following.

/tool mac-server
add disabled=yes interface=all
/tool mac-server ping
set enabled=no
/ip firewall filter
add action=drop chain=input comment="block mikrotik discovery" disabled=no dst-port=5678 protocol=udp
add action=drop chain=input comment="ALL WINBOX REQUEST By MAC Address" disabled=no dst-port=20561 protocol=udp
add action=drop chain=input comment="ALL WINBOX REQUEST EXCEPT FROM MY PC" disabled=no dst-port=8291 protocol=tcp src-address=!192.168.2.6

You can Also Disable Network Neighbor Discovery on the interface to which your network users are connected

Example: /ip neighbor discovery set ether1 discover=no

source : https://aacable.wordpress.com/tag/lock-download-based-on-file-size/

A BETTER APPROACH ON BLOCKING PORTS !

/ip firewall mangle
add action=add-src-to-address-list address-list=Worm-Infected-p445 address-list-timeout=1h chain=prerouting connection-state=new disabled=no dst-port=445 limit=5,10 protocol=tcp
/ip firewall filter
add action=drop chain=forward disabled=no dst-port=445 protocol=tcp src-address-list=Worm-Infected-p445
add action=drop chain=forward disabled=no dst-port=445 protocol=tcp src-address-list=Worm-Infected-p445
source : https://aacable.wordpress.com/tag/lock-download-based-on-file-size/

HOWTO PREVENT VIRUS / PORTS FLOODING ?

A basic Mikrotik Firewall Script to secure MT box from virus and flooding. First copy all contents of below script to notepad, then carefully read it.

/ip firewall filter
# To Block ICMP on your WAN Interface
add action=drop chain=input comment="Block ICMP on WAN interface" in-interface=pppoe-out1 protocol=icmp
# Add flooding ips coming from the internet to the Blocked List for 1 mnt
add action=jump chain=forward connection-state=new jump-target=block-ddos
add action=drop chain=forward connection-state=new dst-address-list=ddosed src-address-list=ddoser
add action=return chain=block-ddos dst-limit=50,50,src-and-dst-addresses/10s
add action=add-dst-to-address-list address-list=ddosed address-list-timeout=1m chain=block-ddos
add action=add-src-to-address-list address-list=ddoser address-list-timeout=1m chain=block-ddos
# Block DNS Request on INCOMING WAN INTERFACE
add action=drop chain=input comment="BLOCK DNS REQUEST ON WAN INTERFACE" dst-port=53 in-interface=pppoe-out1 protocol=udp
# Block PORT Scanner Users for 2 minutes
add action=drop chain=input comment="ping port scanners" src-address-list="port scanners"
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2m chain=input comment="Port scanners to list " protocol=tcp psd=21,3s,3,1
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2m chain=input comment="NMAP FIN Stealth scan" protocol=tcp tcp-flags=fin,!syn,!rst,!psh,!ack,!urg
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2m chain=input comment="SYN/FIN scan" protocol=tcp tcp-flags=fin,syn
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2m chain=input comment="SYN/RST scan" protocol=tcp tcp-flags=syn,rst
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2m chain=input comment="FIN/PSH/URG scan" protocol=tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=30m chain=input comment="ALL/ALL scan" protocol=tcp tcp-flags=fin,syn,rst,psh,ack,urg
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2m chain=input comment="NMAP NULL scan" protocol=tcp tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg
# Block Common Virus Ports
add action=drop chain=virus comment="Blaster Worm" dst-port=135-139 protocol=tcp
add action=drop chain=virus comment="Blaster Worm" dst-port=445 protocol=tcp
add action=drop chain=virus comment="Messenger Worm" dst-port=135-139 protocol=udp
add action=drop chain=virus comment="Blaster Worm" dst-port=445 protocol=udp
add action=drop chain=virus comment=________ dst-port=593 protocol=tcp
add action=drop chain=virus comment=________ dst-port=1024-1030 protocol=tcp
add action=drop chain=virus comment=MyDoom dst-port=1080 protocol=tcp
add action=drop chain=virus comment=________ dst-port=1214 protocol=tcp
add action=drop chain=virus comment="ndm requester" dst-port=1363 protocol=tcp
add action=drop chain=virus comment="ndm server" dst-port=1364 protocol=tcp
add action=drop chain=virus comment="screen cast" dst-port=1368 protocol=tcp
add action=drop chain=virus comment=hromgrafx dst-port=1373 protocol=tcp
add action=drop chain=virus comment=cichlid dst-port=1377 protocol=tcp
add action=drop chain=virus comment="Bagle Virus" dst-port=2745 protocol=tcp
add action=drop chain=virus comment=Dumaru.Y dst-port=2283 protocol=tcp
add action=drop chain=virus comment=Beagle dst-port=2535 protocol=tcp
add action=drop chain=virus comment=Beagle.C-K dst-port=2745 protocol=tcp
add action=drop chain=virus comment=MyDoom dst-port=3127-3128 protocol=tcp
add action=drop chain=virus comment="Backdoor OptixPro" dst-port=3410 protocol=tcp
add action=drop chain=virus comment=Sasser dst-port=5554 protocol=tcp
add action=drop chain=virus comment=Beagle.B dst-port=8866 protocol=tcp
add action=drop chain=virus comment=Dabber.A-B dst-port=9898 protocol=tcp
add action=drop chain=virus comment=Dumaru.Y dst-port=10000 protocol=tcp
add action=drop chain=virus comment=MyDoom.B dst-port=10080 protocol=tcp
add action=drop chain=virus comment=NetBus dst-port=12345 protocol=tcp
add action=drop chain=virus comment=Kuang2 dst-port=17300 protocol=tcp
add action=drop chain=virus comment=SubSeven dst-port=27374 protocol=tcp
add action=drop chain=virus comment="PhatBot, Agobot, Gaobot" dst-port=65506 protocol=tcp
add action=jump chain=forward comment="jump to the virus chain" jump-target=virus
add chain=input comment="Accept established connections" connection-state=established
add chain=input comment="Accept related connections" connection-state=related
add action=drop chain=input comment="invalid connections" connection-state=invalid
add chain=input comment=UDP protocol=udp
add action=drop chain=forward comment="invalid connections" connection-state=invalid
# Script Ends Here

Free Remote Desktop

Berikut adalah beberapa layanan Remote Desktop Gratis yang tersedia di Internet. Masing-masing memiliki karakteristik serta fitur yang berbeda. Beberapa di antaranya merupakan layanan berbasis web di mana kita harus terlebih dahulu mendaftar dan melakukan instalasi satu program kecil, ada pula yang bersifat stand alone sehingga mengakses komputer dapat dilakukan lewat jalur VPN. Selain itu ada pula yang berkemampuan untuk berbagi layar desktop bagi lengkap dengan fasilitas chat dan VOIP yang biasanya berguna untuk melakukan pelatihan atau presentasi jarak jauh dan bahkan ada pula yang memungkinkan kita untuk melakukan remote desktop melalui handphone atau PDA.

Yuugu
Menggunakan Yuuguu untuk berbagi layar desktop via Web, anda dapat meminta peserta untuk berbagi kontrol layar dan bekerja sama secara real time melalui web. Sangat membantu untuk bekerja sama menyuntung sebuah dokumen, mempercepat proses pembuatan dokumen dan presentasi secara online.

LogMeIn
Cukup instal LogMeIn pada komputer yang ingin diakses dan kita akan dapat melakukan remote terhadap PC atau Mac dari mana saja hanya menggunakan sebuah browser. Apapun dapat dilakukan seolah-olah secara fisik berada di depan PC atau Mac yang sedang di remote.

CrossLoop
CrossLoop memungkinkan kita untuk melihat layar, kendali atas mouse dan keyboard pada komputer remote. Dalam promosinya CrossLoop dapat dijalankan dalam waktu kurang dari 2 menit. Cukup download dan instal aplikasi dan akan secara otomatis mengkonfigurasi sendiri untuk lingkungan jaringan komputer anda.

ShowMyPC
ShowMyPC memungkinkan kita untuk berkolaborasi dalam melakukan Remote Desktop. Cocok sebagai alternatif untuk yang Anda yang sudah biasa menggunakan WebEx atau Gotomypc. Beberapa kelebihannya antara lain gratis, tidak perlu instalasi, pendaftaran, tidak perlu login. Juga memiliki fitur chatting, White-Board dan mampu merekam layar. Dibangun menggunakan standar SSH VNC serta menyediakan layanan Premium Hosting.

SkyFex
Menggunakan SkyFex Remote Assitant memungkinkan kita menyaksikan dan mengakses komputer dari jauh secara real time. Skyfex tidak memerlukan tambahan software dan bekerja melalui proxy, firewall atau NAT pada jaringan. SkyFex adalah layanan berbasis Windows dan membutuhkan Internet Explorer.

TeamViewer

Selain dapat melakukan remote desktop, TeamViewer dilengkapi dengan fitur transfer file yang memungkinkan kita menyalin file dan folder dari dan ke komputer yang sedang diakses. Untuk memasang TeamViewer tidak diperlukan hak Administrator. Cukup jalankan software dan jangan lupa untuk mematikannya setelah selesai. Jika menggunakan TeamViewer tidak perlu khawatir tentang firewall karena TeamViewer akan menemukan cara komunikasi secara otomatis. Untuk penggunaan non-komersial tersedia secara gratis.

Gooer

Pertama kita harus mengunduh dan menginstal Gooer pada semua komputer yang ingin diakses. Setelah itu komputer dapat diakses menggunakan PC atau perangkat Mobile. Pengguna PC bisa menggunakan sebuah browser (IE, Firefox atau web browser lain yang mendukung Java) sedangkan pengguna mobile dapat mengunjungi wap.gooer.com untuk mendapatkan aplikasi berbasis Java yang tersedia untuk klien perangkat Mobiles/PDA. Jika ingin mengakses remote komputer melalui ponsel atau PDA, Anda harus memasang di atas Gooer Host Software PC ke host pertama, setelah itu Anda dapat men-download software ini, Anda kirimkan ke perangkat mobile dan menginstalnya.

Microsoft SharedView
Untuk memulai sesi program ini Anda harus terlebih dahulu sign in menggunakan Windows Live ID. Jika Anda ingin memulai sesi dan tidak memiliki Windows Live ID, Anda dapat menginstalas program ini namun sebelum masuk, Anda tetap memiliki Windows Live ID.

Yakkle
Yakkle dibangun menggunakan platform Java. Fungsi remote desktop sharing sebenarnya hanya salah satu fitur yang tersedia selain Instant Messaging, File Sharing, Video dan Conference. Yakkle dapat saling berkomunikasi dengan Gmail serta Jabber. Yakkle juga mampu berintegrasi dengan account Twitter.

DimDim
Dimdim Web Meeting tersedia dalam edisi open source maupun komersiil yang mampu mendukung ribuan peserta. Tidak seperti layanan web meeting sebelumnya, Dimdim tersedia secara online atau kita juga dapat menginstalnya di server pribadi.

Desktra

Untuk menggunakan DESKTRA, unduh dulu file “FreedomSetup1_1.exe”, instal pada PC yang ingin diakses dari internet. PC ini disebut “HOST”. Windows perlu reboot untuk menyelesaikan instalasi. Setelah reboot gunakan akun yang sama saat meng-install DESKTRA untuk melanjutkan proses instalasi. PC tersebut akan dipromosikan dengan DESKTRA Freedom Desktop Server Control Panel. ID baru otomatis dibuat ketika “DESKTRA Freedom Server.exe” berjalan untuk pertama kalinya. Isi password yang Anda inginkan dan klik tombol “Start” untuk memulainya.

Remobo

Beberapa keunggulan yang dimilikinya:

* Zero-Configuration: instal dan Anda siap digunakan! Tidak perlu konfigurasi yang rumit mengubah setting jaringan, ataupun firewall untuk memulainya.
* Mudah pakai: akses komputer dari manapun selama dalam dalam daftar Anda dunia!
* Aman: semua data dienkripsi dan private agar tidak ada orang lain dapat melihatnya. Tentu saja NO spyware atau adware apapun!
* Cepat: Remobo akan mencoba untuk membuat koneksi secara langsung atau peer-to-peer antara komputer untuk mendapatkan kecepatan terbaik.
* Fleksibel: dilengkapi dengan akses remote desktop, file sharing & VPN.

source :  udaramaya.com

Link State Advertisements Types

Understanding all the OSPF LSA types is one of the keys to understanding OSPF, so its definatly worth me making a few notes on them

LSA type 1 – Router LSAs are sent from a router to other routers in the same area. It contains information regarding the routers interfaces in the same area, relevant interfaces IPs, its adjacent routers on those interfaces and sub networks

LSA type 2 – Network LSAs are generated by the DR on a multi access segment, and provides similar information to an LSA type 1 for the multi access segment and subnet which it belongs

LSA type 3 – Network Summary LSAs are generated by ABRs and contain the subnets & costs but omit the topological data from all subnets in one area and sent to another area via the ABR

LSA type 4 -ASBR summary LSAs are from ASBRs and are identical in structure to a type 3 LSA and sent when crossing an AS boundary

LSA type 5 -Are AS external LSAs which are originated by ASBRs and describe external networks

LSA type 6 – Is defined as a Group Membership LSA but not used in Cisco devices

LSA type 7 -NSSA External LSAs are generated by the ASBR in an NSSA area

LSA type 8 – Is defined as a External Attribute LSA but not used in Cisco devices

LSA types 9 to 11 – Defined as Opaque LSAs and are reserved for future expansion